New Ytest
Sign out
Bimmerpost
Login
BMW E39 5-Series Forum | 5Post.com
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  
Go Back   BMW E39 5-Series Forum | 5Post.com > BMW 5-Series (E39) Forums (1995 - 2003) > General E39 Discussions

Post Reply
 
Thread Tools Search this Thread
      03-22-2023, 05:01 AM   #1
crnisin
Registered
0
Rep
2
Posts

 
Drives: E39 525d 163hp
Join Date: Mar 2023
Location: Serbia

iTrader: (0)

E39 525d 2001 163hp - can't connect diagnostics

My e39 is obd2 only (no 20 pin jack under hood). My scan tool gets power from the car but cant communicate with any module. I bridged pins 7 and 8 and got some communication like Abs, but still cant connect to engine DME. Any help?
Appreciate 0
      03-22-2023, 03:50 PM   #2
crnisin
Registered
0
Rep
2
Posts

 
Drives: E39 525d 163hp
Join Date: Mar 2023
Location: Serbia

iTrader: (0)

Update,
I have a diagram of the obd2 port and everything seems to be in order, but still no communication with DME. I left the car in on position (not running) for about 10 minutes and it accesed DME. What i find strange is no DTC codes can be found and usualy my scan tool lets me see a lot of things, now i can only read trouble codes, its the only clickable option. Also I can access Steering Angle Sensor but when i go to data stream all the variables can not be read and it only says "No communication with ECU".
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:31 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST