BMW E39 5-Series Forum | 5Post.com
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  
Go Back   BMW E39 5-Series Forum | 5Post.com > BMW 5-Series (E39) Forums (1995 - 2003) > General E39 Discussions

Post Reply
 
Thread Tools Search this Thread
      09-23-2013, 11:56 AM   #1
yellowllewellyn
Private
 
Drives: 2014 335i xDrive
Join Date: May 2012
Location: Ky

Posts: 70
iTrader: (0)

1999 540i electrical issue.

Hello,

I have a 1999 540i with a 6 speed manual. Ive been having electric issues. The car will randomly not start due to the battery being drained by something. The car drives just fine, with no warning lights on. However the cars alarm will randomly go off and then stop after 2 or 3 minutes. The car will lock itself when i shut the trunk. The alarm will also go off when unlocking the car every now an then when using the key fob, and also alway when using my spare key for the first time after using the original key. The car will also randomly lock whenever i turn the car off. Im assuming there is something in the locking system that is causing the battery to drain. The car will sometimes be find for weeks at a time and then one day just be dead in a parking lot. and sometimes it will happen multiple times in a week. The battery is brand new and i have replaced it a few times just incase. I have taken it to my trusted workshop many times and they can not find the issue. They left it on a monitor for a week and the saw no battery draw. They even drove the car around alittle to see if they could trip it. Nothing. Does anyone have any ideas?

Thanks so much.
yellowllewellyn is offline  
0
Reply With Quote
      09-27-2013, 08:00 PM   #2
supra94tt
New Member
 
Drives: 2000 540
Join Date: Jun 2008
Location: New Jersey Republic

Posts: 13
iTrader: (0)

Hmm..... sounds like one of your door lock actuators and/or door latch assy. is kaput, Im surprised that scanning the car did not show anything(unless it was not a BMW equipment?).
supra94tt is offline   United_States
0
Reply With Quote
      11-01-2013, 03:07 PM   #3
AGM5
Enlisted Member
 
AGM5's Avatar
 
Drives: E39 M5
Join Date: Nov 2012
Location: TARDIS

Posts: 49
iTrader: (0)

Garage List
Unplug the hood switch (it is in front of the left (driver's side US)) cabin filter and see if the battery drain and random alarm issues don't go away.

This is a common problem on the e39s.
__________________
///M
1 of 75 ANTHRAZIT METALLIC (397) / WALK NAPPA/SCHWARZ (M1SW)
348.64 WHP / 343.65WTQ Tuned by BMW Motorsports 4/2001 Bone Stock at 145,000Miles.
AGM5 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:12 PM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST