BMW E39 5-Series Forum | 5Post.com
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  
Go Back   BMW E39 5-Series Forum | 5Post.com > BMW 5-Series (E39) Forums (1995 - 2003) > General E39 Discussions

Post Reply
 
Thread Tools Search this Thread
      06-12-2013, 01:42 PM   #1
530dE39
New Member
 
Drives: 530d E39 12-2002
Join Date: Mar 2011
Location: Warsaw, PL

Posts: 11
iTrader: (0)

Garage List
2003 E39 sedan  [0.00]
no frosty / really cold air from climate control

Hi,

Since the weather finally starts getting better and temperature is rising I noticed that my climate control somehow doesn't seem to work.

When I press the snow-flake button, it does somehow seem to blow faster, the speed is controlled by temperature setting (speed goes down the more I reach outside temperature).

However, while having 28-30 degrees C outside and AC set to 20 it doesn't blow cold. Even on the min. of 16 C it still isn't frosty cold. Definitely not as it used to be.

What can cause this? I don't have any error messages or something on my display or something.

Thanks!!

E39 530d (2003)
530dE39 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:10 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST