BMW E39 5-Series Forum |
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  
Go Back   BMW E39 5-Series Forum | > BMW 5-Series (E39) Forums (1995 - 2003) > General E39 Discussions

Post Reply
Thread Tools Search this Thread
      06-12-2013, 02:42 PM   #1
New Member

Drives: 530d E39 12-2002
Join Date: Mar 2011
Location: Warsaw, PL

iTrader: (0)

Garage List
2003 E39 sedan  [5.00]
no frosty / really cold air from climate control


Since the weather finally starts getting better and temperature is rising I noticed that my climate control somehow doesn't seem to work.

When I press the snow-flake button, it does somehow seem to blow faster, the speed is controlled by temperature setting (speed goes down the more I reach outside temperature).

However, while having 28-30 degrees C outside and AC set to 20 it doesn't blow cold. Even on the min. of 16 C it still isn't frosty cold. Definitely not as it used to be.

What can cause this? I don't have any error messages or something on my display or something.


E39 530d (2003)
Appreciate 0
Post Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:25 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.,,,,,,,,, logo and trademark are properties of BIMMERPOST